Issues porting the Nokia 5110 to support bluepill

The official STMicroelectronics Arduino core
User avatar
BennehBoy
Posts: 67
Joined: Tue Mar 05, 2019 7:43 pm
Location: Yorkshire
OS: Windows 10
IDE: 1.8.9, Sloeber
Core: Roger's & STM
Board: Blue/Blackpill, MM, HYTiny, Black407Z/VET6, DiyMroe, FK407M1
Contact:

Re: Issues porting the Nokia 5110 to support bluepill

Post by BennehBoy » Mon Mar 18, 2019 9:32 pm

hierophect wrote:
Mon Mar 18, 2019 4:51 pm
Do you mean you've had issues when attempting to SPI bus share, or that you've taken extra steps regarding SPI bus sharing?
I mean I've had issues with libraries bus sharing.

The only library that I think I had to tweak was the SSD1351 library, it set the clock divider too high and was trying to operate at 36mhz.

TBH Adafruit need to overhaul their SPI handling, they have a different implementation in every lib which is a bit crackers.
-Ben

hierophect
Posts: 14
Joined: Tue Mar 12, 2019 10:17 pm

Re: Issues porting the Nokia 5110 to support bluepill

Post by hierophect » Tue Mar 19, 2019 2:33 pm

Never really understood that fully. I guess maybe it's because many of their libraries are scavenged from the permissive license community and just given a coat of paint? Really wish somebody could figure out how to make the maintenance and standardization of device libraries their whole business model so they can fix all these weird issues.
OS IDE Core Board
[ ] Windows
[ ] Linux
[x] Mac OS
[x] Arduino 1.8.8
[ ] PlatformIO
[ ] Sloeber
[ ] Roger's
[x] STM
[ ] Else
[x] Blue pill
[x] Custom F103
[ ] Black pill

Post Reply